Docly

Elementor Not Working ? Server Requirements for Elementor

Estimated reading: 1 minute 198 views

Here are the system requirements you need in order to use Elementor.
(If you are not sure whether or not your server supports this, contact your host).

WordPress 5.0 or Greater

Elementor works with WordPress version 5.0 or greater

PHP 7 or Greater

Note: If your site is hosted on a server with an older PHP, you may experience issues. We recommend you contact your hosting provider to upgrade to the latest version of PHP.

Elementor may also work with PHP 5.4+, but these older versions have reached official End Of Life and as such may expose your site to security vulnerabilities and bugs, and may not always work as expected.

MySQL 5.6 or Greater

MySQL version 5.6 or greater OR MariaDB version 10.0 or greater

WP Memory Limit

WP Memory limit of 128 MB or greater (256 MB or higher is preferred)

For more information please read the official website server requirements for Elementor page builder.

https://elementor.com/help/requirements/

Leave a Comment

CONTENTS